MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000999luatexluatex bugpublic2017-09-08 09:312017-10-02 09:23
Reporterwiz 
Assigned To 
PrioritynormalSeveritymajorReproducibilityalways
StatusnewResolutionopen 
Platformamd64OSNetBSDOS Version8.99.2
Product Version1.0.0 
Target VersionFixed in Version 
Summary0000999: luatex: use public poppler API
Descriptionluatex uses the xpdf compatibility API provided by poppler.

However, upstream poppler sees this as "unsupported" and changes it when and how they want, see e.g. http://tracker.luatex.org/view.php?id=998 [^]

Their view is that consumers should use one of the public APIs, i.e. the glib, qt4, qt5, or cpp ones.

Please switch luatex to use one of those. If the API provided by upstream does not fulfill luatex's needs, upstream is willing to talk
(https://lists.freedesktop.org/mailman/listinfo/poppler [^]).

(I'm not upstream, I'm just a packager that would like to reduce future breakage.)
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0001676)
luigi scarso (developer)
2017-09-20 12:25

Thank you for the report, we are trying now to compile experimental with poppler 0.59.
(0001677)
luigi scarso (developer)
2017-10-02 09:22
edited on: 2017-10-02 09:23

Revision 6408 im experimental has poppler 0.59.0.


- Issue History
Date Modified Username Field Change
2017-09-08 09:31 wiz New Issue
2017-09-20 12:25 luigi scarso Note Added: 0001676
2017-10-02 09:22 luigi scarso Note Added: 0001677
2017-10-02 09:23 luigi scarso Note Edited: 0001677 View Revisions


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker