View Issue Details

IDProjectCategoryView StatusLast Update
0000974luatexluatex bugpublic2016-05-24 13:42
ReporterjengelsdAssigned ToHans Hagen 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version0.96.0 
Summary0000974: vsplit box with unbreakable content differs from pdftex
DescriptionThe following example changes behavior from luatex 0.80 in TeX Live 2015 to the build of version 0.95 in the current TeX Live 2016 pretest. Luatex 0.80 and pdftex both produce the same output (the height of the split box is 5pt). With 0.95 this value is 16.30554pt. I'm not sure if this behavior is the intended behavior.

Here is the test file:

\newbox\mainbox
\newbox\splitbox

\setbox\mainbox=\vbox{%
  \vbox{a \par b}
}

\setbox\splitbox=\vsplit\mainbox to 5pt

\the\ht\splitbox

\bye
TagsNo tags attached.

Activities

jengelsd

2016-05-24 04:13

reporter   ~0001607

Actually, I just tried to build from the experimental branch and this issue is resolved there. Looks like revision 6017.

luigi scarso

2016-05-24 09:33

developer   ~0001608

Yes, also see the manual (subsection 1.13.3) for \vsplit upto

Issue History

Date Modified Username Field Change
2016-05-23 18:54 jengelsd New Issue
2016-05-24 04:13 jengelsd Note Added: 0001607
2016-05-24 09:33 luigi scarso Note Added: 0001608
2016-05-24 13:42 Hans Hagen Status new => closed
2016-05-24 13:42 Hans Hagen Assigned To => Hans Hagen
2016-05-24 13:42 Hans Hagen Resolution open => fixed
2016-05-24 13:42 Hans Hagen Fixed in Version => 0.96.0