View Issue Details

IDProjectCategoryView StatusLast Update
0000966luatexluatex limitationpublic2016-03-10 18:16
ReporterKalrishAssigned Toluigi scarso 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformAllOSOS Version
Product Version0.81.0 
Target VersionFixed in Version0.90.0 
Summary0000966: LuaJITTeX's `loadfile` behaves like 5.1 while `load` behaves like 5.2
DescriptionLuaJIT is fully upwards-compatible with Lua 5.1 and also supports some language and library extensions from Lua 5.2 (see http://luajit.org/extensions.html). Among them are versions of `load` and `loadfile` with an `env` parameter that allows to set the environment under which the chunk shall be loaded (see the pertinent section of the [Lua 5.2 Reference Manual](http://www.lua.org/manual/5.2/manual.html#pdf-load)). Currently, LuaJITTeX supports 5.2's `load` but its `loadfile` behaves like 5.1. This is incoherent and seems unintended.
Steps To ReproduceRun `luajittex --interaction=nonstopmode -- main.tex`.

Expected output:
load: success
loadfile: success
Additional Informationfixed in rev. 5829
TagsNo tags attached.

Activities

Kalrish

2016-02-26 18:14

reporter  

luajittex-loadfile-5.2.tar (4,096 bytes)

luigi scarso

2016-02-26 21:47

developer   ~0001578

Thank you for the report. I will see it asap.

Issue History

Date Modified Username Field Change
2016-02-26 18:14 Kalrish New Issue
2016-02-26 18:14 Kalrish File Added: luajittex-loadfile-5.2.tar
2016-02-26 21:47 luigi scarso Note Added: 0001578
2016-03-06 18:08 Hans Hagen Status new => closed
2016-03-06 18:08 Hans Hagen Assigned To => luigi scarso
2016-03-06 18:08 Hans Hagen Resolution open => fixed
2016-03-06 18:08 Hans Hagen Fixed in Version => 0.90.0
2016-03-10 18:16 Hans Hagen Additional Information Updated View Revisions