View Issue Details

IDProjectCategoryView StatusLast Update
0000934luatexluatex bugpublic2015-05-14 12:51
ReporterkarlberryAssigned ToHans Hagen 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version0.80.1 
Summary0000934: 0.80.0 This can't happen (sub_disc_widths)
DescriptionThis fatal error happens on the attached Russian latex document with luatex 0.80.0 in the current TL'15 pretest, and not with luatex 0.79.1 from TL 2014.
I'm on i386-linux, though hopefully that doesn't matter.

Of course it would be nicer to reproduce it with plain luatex, but discerning all the right line-breaking parameters and loading the font would take a lot of time. Since it's a fatal error, I hoped this would be enough and the problem would become obvious.

Evidently some unexpected type(s) is happening in the switch statement in sub_from_widths. gdb tells me that s is the number 13360, but I don't know what "type" that is without more delving.

Fingers crossed ...
Steps To Reproducelualatex subdisc.tex
...
! This can't happen (sub_disc_widths)
l.15

Additional InformationOriginally reported at http://tug.org/pipermail/tex-live/2015-April/036657.html by Yuri Skryabin <skryabin@imp.uran.ru>. He sent me a test file, which I cut down further.

By the way, the "Product Version" field in this tracker needs to be updated to include 0.80.0.
TagsNo tags attached.

Activities

karlberry

2015-04-30 20:09

reporter  

subdisc.tex (596 bytes)

luigi scarso

2015-05-04 18:37

developer   ~0001360

Thank you for the report, we are investigating. It's a regression due a patch for a similar issue for the Type1 fonts.

Issue History

Date Modified Username Field Change
2015-04-30 20:09 karlberry New Issue
2015-04-30 20:09 karlberry File Added: subdisc.tex
2015-05-04 18:37 luigi scarso Note Added: 0001360
2015-05-14 12:51 Hans Hagen Status new => closed
2015-05-14 12:51 Hans Hagen Assigned To => Hans Hagen
2015-05-14 12:51 Hans Hagen Resolution open => fixed
2015-05-14 12:51 Hans Hagen Fixed in Version => 0.80.1