View Issue Details

IDProjectCategoryView StatusLast Update
0000875luatexluatex bugpublic2015-10-20 20:20
ReporterTacoAssigned ToHans Hagen 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version0.80.2 
Summary0000875: Solve duplicate generated glyph names issue
DescriptionCurrent luatex (0.78.2) sometimes creates identical duplicate glyph names for unnamed glyphs from opentype fonts.

Steps To ReproduceA good example font is palatino from windows (ttf file). It has two versions of a 'smallcaps i': with and without dot. Both glyphs are unnamed in the font itself, so the fontloader generates a nice name for it by using the basename + feature tag, resulting in i.sc. But it finds that same name for both glyphs!

This is problematic, because the otf lookups are converted in the output to use such names instead of the (original) glyph ids.
Additional InformationIt is not too hard to create a different naming convention and/or uniquifying the generated names, but it is not quite clear how important the naming convention is within context and luaotfload for use in the creation of tounicode data (pdf search/cut&paste).
TagsNo tags attached.

Activities

Hans Hagen

2014-04-24 09:55

manager   ~0001271

I'd rather do all the tounicode logic at the lua end (in fact it already happens to a large extent as we need to catch some weird glyph names - done together with kaj e. Maybe best is to avoid glyph names in the lookup tables and use indices instead. There is no need to fight hard-codes heuristics then. (I want to have a look at that later this year).

Issue History

Date Modified Username Field Change
2014-01-13 14:18 Taco New Issue
2014-04-24 09:55 Hans Hagen Note Added: 0001271
2015-03-21 15:13 Hans Hagen Assigned To => Hans Hagen
2015-03-21 15:13 Hans Hagen Status new => assigned
2015-10-19 18:44 Hans Hagen Status assigned => closed
2015-10-19 18:44 Hans Hagen Resolution open => fixed
2015-10-19 18:54 Hans Hagen Status closed => resolved
2015-10-19 18:54 Hans Hagen Fixed in Version => 0.80.2
2015-10-20 20:20 Hans Hagen Status resolved => closed