View Issue Details

IDProjectCategoryView StatusLast Update
0000822luatexluatex bugpublic2015-10-06 15:25
ReporterTacoAssigned ToHans Hagen 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0000822: 'command' vs 'cmd' confusion in whatsit colorstack node fields
DescriptionFrom Patrick:


(this time it's the flollowing code:

---------
\catcode`\{=1 \catcode`\}=2
\directlua{
for k,v in pairs(node.fields(8,39)) do
  print(k,v)
 end
% prints '5 cmd'
    c = node.new(8,39)
    c.cmd = 1
}

\end
---------
which yields

! LuaTeX error [string "\directlua "]:1: You cannot set field cmd in a node of type whatsit
Additional InformationThe problem is with node.setfield(), which expects 'command' here, instead of 'cmd'. 'cmd' is in the manual, so that is what it should be changed to.
TagsNo tags attached.

Activities

Paul Isambert

2013-06-04 17:43

reporter   ~0001093

"c.cmd" doesn't work anymore (it returns nil, "c.command" should be used instead for getting the value too), even though node.fields still lists it. So it's more than just the manual.

Issue History

Date Modified Username Field Change
2013-04-08 15:53 Taco New Issue
2013-06-04 17:43 Paul Isambert Note Added: 0001093
2015-10-06 15:25 Hans Hagen Status new => closed
2015-10-06 15:25 Hans Hagen Assigned To => Hans Hagen
2015-10-06 15:25 Hans Hagen Resolution open => fixed