View Issue Details

IDProjectCategoryView StatusLast Update
0000820luatexluatex bugpublic2013-12-20 10:01
ReporterpatrickAssigned ToTaco 
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionno change required 
PlatformApple/Intel/64bitOSOS XOS Version10.6
Product Version0.74.0 
Target VersionFixed in Version 
Summary0000820: !LuaTeX error (file texgyreheros-regular.otf): Parsing CFF DICT failed. (error=-1)
DescriptionWhen running the attached files, I get the following error:

./luatex --ini --lua inifile.lua sample.tex
This is LuaTeX, Version beta-0.75.0-2013030308 (rev 4589) (INITEX)
(sample.tex
Overfull \hbox (22.78pt too wide) in paragraph at lines 26--28
[][]\texgyre Hello
[0] )
(see the transcript file for additional information)<texgyreheros-regular.otf
!LuaTeX error (file texgyreheros-regular.otf): Parsing CFF DICT failed. (error=
-1)
 ==> Fatal error occurred, no output PDF file produced!
Steps To Reproduceunzip the attached zip archive
change into the directory
run "luatex --ini --lua inifile.lua sample.tex"
Additional InformationThis happens to me on OS X (newest binary, newest distribution) and on Windows 64 bit.
TagsNo tags attached.

Activities

patrick

2013-04-07 14:28

reporter  

cfferror.zip (496,494 bytes)

patrick

2013-04-07 14:29

reporter   ~0001069

Observation: when I change the beginning of "inifile.lua" to

texconfig.kpse_init=false
kpse.set_program_name("luatex")

and comment out the line 'callback.register('find_opentype_file',return_asked_name)'

everything looks fine.

Taco

2013-04-08 10:28

administrator   ~0001070

Hi Patrick,

Here is what I get with the newly released luatex 0.76.0 on OSX/64 (10.8.3):

$ luatex --ini --lua inifile.lua sample.tex
This is LuaTeX, Version beta-0.76.0-2013040810 (rev 4627) (INITEX)
(sample.tex
Overfull \hbox (22.78pt too wide) in paragraph at lines 26--28
[][]\texgyre Hello
[0] )
(see the transcript file for additional information)<texgyreheros-regular.otf>
Output written on sample.pdf (1 page, 3052 bytes).
Transcript written on sample.log.

Taco

2013-04-08 10:28

administrator   ~0001071

Can you please check the latest version from foundry.supelec.fr ?

patrick

2013-04-08 11:05

reporter   ~0001072

Works for me as well with "LuaTeX, Version beta-0.77.0-2013040811 (rev 4632) (INITEX)"

Thanks & sorry for the noise!

Taco

2013-04-08 11:21

administrator   ~0001073

fixed somewhere inbetween 4589 and 4627.

Hans Hagen

2013-12-20 10:01

manager   ~0001184

closed in 0.78

Issue History

Date Modified Username Field Change
2013-04-07 14:28 patrick New Issue
2013-04-07 14:28 patrick File Added: cfferror.zip
2013-04-07 14:29 patrick Note Added: 0001069
2013-04-08 10:28 Taco Note Added: 0001070
2013-04-08 10:28 Taco Note Added: 0001071
2013-04-08 10:28 Taco Status new => feedback
2013-04-08 11:05 patrick Note Added: 0001072
2013-04-08 11:05 patrick Status feedback => new
2013-04-08 11:21 Taco Note Added: 0001073
2013-04-08 11:21 Taco Status new => resolved
2013-04-08 11:21 Taco Resolution open => no change required
2013-04-08 11:21 Taco Assigned To => Taco
2013-12-20 10:01 Hans Hagen Note Added: 0001184
2013-12-20 10:01 Hans Hagen Status resolved => closed