View Issue Details

IDProjectCategoryView StatusLast Update
0000804MetaPostbugpublic2013-02-18 15:01
ReporterTacoAssigned ToTaco 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version1.780 
Target VersionFixed in Version 
Summary0000804: weird division parser bug
Descriptiondef calc(expr a)=
  A = 360/a;
enddef;
calc(5);
end.

gives A = 1, because it somehow produces

(EXPR0)<-5
{(5)/(5)}
{(A)=(1)}

internally.
TagsNo tags attached.

Activities

Taco

2013-02-01 16:08

administrator   ~0001032

360/(a) works fine, btw.

Taco

2013-02-01 16:42

administrator   ~0001033

fixed (but this bug has the potential to appear more than once, the problem is that mp_make_exp_copy () trashes the value inside the mp_number in mp->cur_exp, and that may or may not be stored and needed later on. See |mp_cur_tok| for the current solution.)

Issue History

Date Modified Username Field Change
2013-02-01 16:08 Taco New Issue
2013-02-01 16:08 Taco Status new => assigned
2013-02-01 16:08 Taco Assigned To => Taco
2013-02-01 16:08 Taco Note Added: 0001032
2013-02-01 16:42 Taco Note Added: 0001033
2013-02-01 16:42 Taco Status assigned => resolved
2013-02-01 16:42 Taco Resolution open => fixed
2013-02-18 15:01 Taco Status resolved => closed