View Issue Details

IDProjectCategoryView StatusLast Update
0000801luatexluatex bugpublic2015-10-22 10:49
ReporteroneirosAssigned Tooneiros 
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Platformx86_64OSLinuxOS Version3.4.11
Product Version 
Target VersionFixed in Version 
Summary0000801: lfs broken with png inclusion
DescriptionLarge File Support is broken in r4555 at least since r4502
Steps To ReproduceRun the attached largepdf.tex in texlive/Build/tests/largefile
Do tail largepdf.pdf

The tail of the resulting will look like this:
0000012337 00000 f
0000012338 00000 f
0000012339 00000 f
0000012340 00000 f
0000000000 00000 f
trailer
<</Size 12341/Root 12339 0 R/Info 12340 0 R/ID[<DECD8320A2EDAC95480BDA9D63BBC099> <DECD8320A2EDAC95480BDA9D63BBC099>]>>
startxref
-1358057986
%%EOF

As one can see, the offsets are wrong, and the xref offset has had an overflow.
TagsNo tags attached.

Relationships

related to 0000951 closedluigi scarso 20 gig pdf files cannot be loaded by the poppler lib 

Activities

oneiros

2013-01-14 00:09

developer  

largepdf.tex (454 bytes)

oneiros

2013-01-14 00:30

developer   ~0001020

From pdfgen.w:
            pdf_puts(pdf, "startxref\n");
            if (pdf->os_enable)
                pdf_add_int(pdf, (int) obj_offset(pdf, xref_stm));
            else
                pdf_add_int(pdf, (int) pdf->save_offset);
            pdf_puts(pdf, "\n%%EOF\n");

oneiros

2013-01-14 00:32

developer   ~0001021

> uname -a
Linux dream 3.4.11-2.16-desktop 0000001 SMP PREEMPT Wed Sep 26 17:05:00 UTC 2012 (259fc87) x86_64 x86_64 x86_64 GNU/Linux

Hans Hagen

2013-12-20 17:38

manager   ~0001193

with 0.78 we can produce a 20 Gig pdf on windows 64 and linux 64 that can be read by acrobat reader on both platforms; however, including pages from that file fails (looks like a poppler issue as poppler based programs cannot handle the large file anyway); we did observe a lua seek issue with the large file

oneiros

2013-12-20 18:46

developer   ~0001195

When I last looked inclusion of PDFs (i.e. poppler) had no LFS. But that's a poppler problem.

Hans Hagen

2013-12-20 19:54

manager   ~0001199

so can we close this item?

Issue History

Date Modified Username Field Change
2013-01-14 00:09 oneiros New Issue
2013-01-14 00:09 oneiros Status new => assigned
2013-01-14 00:09 oneiros Assigned To => oneiros
2013-01-14 00:09 oneiros File Added: largepdf.tex
2013-01-14 00:30 oneiros Note Added: 0001020
2013-01-14 00:32 oneiros Note Added: 0001021
2013-01-14 00:32 oneiros OS => Linux
2013-01-14 00:32 oneiros OS Version => 3.4.11
2013-01-14 00:32 oneiros Platform => x86_64
2013-12-20 17:38 Hans Hagen Note Added: 0001193
2013-12-20 18:46 oneiros Note Added: 0001195
2013-12-20 19:54 Hans Hagen Note Added: 0001199
2015-10-22 10:49 Hans Hagen Issue cloned: 0000951
2015-10-22 10:49 Hans Hagen Relationship added related to 0000951
2015-10-22 10:49 Hans Hagen Status assigned => closed
2015-10-22 10:49 Hans Hagen Resolution open => fixed