View Issue Details

IDProjectCategoryView StatusLast Update
0000074luatexluatex bugpublic2008-09-30 11:49
ReporterTacoAssigned ToTaco 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version0.29.0 
Target Version0.30.0Fixed in Version0.30.0 
Summary0000074: Luatex can't find files without extension
DescriptionFrom Manuel Pégourié-Gonnard

Hi,

I just tried the following:

mpg@siegel:~% echo '\\bye' > foobar
mpg@siegel:~% pdftex foobar
This is pdfTeXk, Version 3.1415926-1.40.9 (Web2C 7.5.7)
 %&-line parsing enabled.
entering extended mode
(./foobar )
No pages of output.
Transcript written on foobar.log.
mpg@siegel:~% luatex foobar
This is LuaTeX, Version snapshot-0.25.4-2008071722 (Web2C 7.5.7)
! I can't find file `foobar.tex'.
<*> foobar

Please type another input file name:

Looks like luatex doesn't want to eat files without extensions, while pdftex
accepts them. Is it a feature?
Additional InformationIt is *does* work if you key in the filename interactively at the error prompt.
TagsNo tags attached.

Activities

Taco

2008-09-23 14:22

administrator   ~0000048

As of #1484, there is no longer a forced ".tex" extension in the web source

Issue History

Date Modified Username Field Change
2008-07-29 17:17 Taco New Issue
2008-07-29 17:17 Taco Status new => assigned
2008-07-29 17:17 Taco Assigned To => Taco
2008-09-23 14:22 Taco Status assigned => resolved
2008-09-23 14:22 Taco Fixed in Version => 0.30.0
2008-09-23 14:22 Taco Resolution open => fixed
2008-09-23 14:22 Taco Note Added: 0000048
2008-09-30 11:49 Taco Status resolved => closed