View Issue Details

IDProjectCategoryView StatusLast Update
0000729luatexluatex bugpublic2015-10-21 14:47
ReporterTacoAssigned ToHans Hagen 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version0.82.0 
Summary0000729: Placement of \limits
DescriptionFrom Johannes:


Next issue I found (*Taco*: LuaTeX bug?):
Limits on integrals are placed too far to the right
(maybe this happens with all bigops which use italic correction to offset limits -- but normally only integrals use italic correction in most fonts).

Take a look at

$\int_{|}^{|}$ $\int\limits_{|}^{|}$

$$\int_{|}^{|}\quad \int\limits_{|}^{|}$$

With "\limits", the limit should be horizontally centered above / below the ending of the integral symbol, respectively.

XeTeX gives besser positioning here.
Tested with MinionMath, Cambria, Xits, Asana; both ConTeXt and LuaLaTeX.


[ In the MATH table spec, italic correction is used in two ways
(I do not understand why they use this parameter overloading here while they split up all other stuff into separate parameters):

(a) italic correction with italic letters followed by upright characters or symbols -- ill-defined, incomprehensible. This should not be implemented / not used, I think; at least not in this way.

(b) to horizontally offset limits on integrals (and slanted bigops)
-- preferably, this should be a separate parameter.
And positioning for "\limits" and "\nolimits" might be different and might need two parameters, e.g. on u+22C0 "n-ary logical and".
]
Tagsmath

Activities

Hans Hagen

2015-10-21 14:47

manager   ~0001458

Because the italic correction can be in the glyoh we might need to compensate for it. The logic is somewhat messy because we need to go into the already assembled nucleus. Therefore this 'fix' is implemented as option:

\mathoption compensateitalic 1

There will be more such options.

Issue History

Date Modified Username Field Change
2011-10-12 15:52 Taco New Issue
2012-04-09 04:37 Khaled Hosny Tag Attached: math
2015-10-21 13:04 Hans Hagen Assigned To => Hans Hagen
2015-10-21 13:04 Hans Hagen Status new => assigned
2015-10-21 14:47 Hans Hagen Note Added: 0001458
2015-10-21 14:47 Hans Hagen Status assigned => closed
2015-10-21 14:47 Hans Hagen Resolution open => fixed
2015-10-21 14:47 Hans Hagen Fixed in Version => 0.82.0