View Issue Details

IDProjectCategoryView StatusLast Update
0000703luatexluatex bugpublic2013-12-23 10:51
ReporterTacoAssigned ToHans Hagen 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionno change required 
Product Version 
Target Versionsubproject (> v 1)Fixed in Version 
Summary0000703: Font embedded twice with different rendering modes
DescriptionFrom Philipp,
>From Pablo, see https://github.com/wspr/unicode-math/issues/208
If you load a font twice using different rendering modes, it gets
embedded twice:

\input luaotfload.sty
\font\1={name:LM Roman 10 Regular:mode=node}\relax
\font\2={name:LM Roman 10 Regular:mode=base}\relax
\1 A
\2 A
\bye

Regards,
Philipp Stephani
TagsNo tags attached.

Activities

Hans Hagen

2013-12-20 10:20

manager   ~0001189

This is a tricky issue. In this example indeed the font could be shared but this is not true when we have completely different slot allocation which can happen (math is an example). In that case luatex would have to analyze a lot more in the backend which for sure would interfere at some other point. (Tounicode vectors is an example).

So, the only safe optimization is to share the shapes (/FontFile3 resource) unless it's also tricky due to order.

I can think of an optional optimization at the lua/tex end but we deliberately have a distinctive psname now to avoid issues and this is what the backend triggers on.

Hans Hagen

2013-12-20 11:28

manager   ~0001191

experimental solution in lua code; that's probably the only place where we can do a check; if it was done in the backend, then we would also need a way to control it; from luatex's perspective, the fullname entry determines sharing and that is by design: different fullnames == no sharing, and that will stay

Issue History

Date Modified Username Field Change
2011-07-17 11:05 Taco New Issue
2011-07-17 11:05 Taco Status new => assigned
2011-07-17 11:05 Taco Assigned To => Taco
2013-12-20 10:20 Hans Hagen Note Added: 0001189
2013-12-20 10:20 Hans Hagen Target Version => subproject (> v 1)
2013-12-20 11:28 Hans Hagen Note Added: 0001191
2013-12-20 11:28 Hans Hagen Status assigned => closed
2013-12-20 11:28 Hans Hagen Assigned To Taco => Hans Hagen
2013-12-20 11:28 Hans Hagen Resolution open => fixed
2013-12-20 12:33 Hans Hagen Status closed => resolved
2013-12-20 12:33 Hans Hagen Resolution fixed => no change required
2013-12-23 10:51 Hans Hagen Status resolved => closed