View Issue Details

IDProjectCategoryView StatusLast Update
0000599luatexdocumentationpublic2011-04-12 11:06
ReporterTacoAssigned ToTaco 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version0.66.0 
Summary0000599: unsetting attributes in the manual
DescriptionFrom MPG:

The manual for version 0.65.0 says (page 16 = pdf page 20)

> > \setbox2=\hbox attr1=12 attr2=-1{Hello}
> >
> > This will set the attribute list of box 2 to 1 = 12, and the attributes of
> > box 0 will be 2 = 5. As you can see, assigning a negative value causes an
> > attribute to be ignored.
Unless I missed something, -1 should be changed to -"7FFFFFFF and the following
sentence adapted accordingly due to changes in luatex 0.37.

Btw, the manual also says (in the same section)

\attribute 16-bit number optional equals 31-bit number

However, the value looks very much like a (signed) 32-bit number to me. Perhaps
the 31-bit thing is also a remnant from the time where only non-negative values
were allowed.

Manuel.

TagsNo tags attached.

Activities

Taco

2011-04-11 10:13

administrator   ~0000776

revision 4118

Taco

2011-04-12 11:06

administrator   ~0000800

all fixed in 0.66.0

Issue History

Date Modified Username Field Change
2011-03-22 09:45 Taco New Issue
2011-04-11 10:12 Taco Status new => assigned
2011-04-11 10:12 Taco Assigned To => Taco
2011-04-11 10:13 Taco Note Added: 0000776
2011-04-11 10:13 Taco Status assigned => resolved
2011-04-11 10:13 Taco Resolution open => fixed
2011-04-12 11:02 Taco Fixed in Version => 0.66.0
2011-04-12 11:06 Taco Note Added: 0000800
2011-04-12 11:06 Taco Status resolved => closed