MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000580contextbug reportpublic2011-02-19 15:072017-03-27 17:15
ReporterPeter 
Assigned ToHans Hagen 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version 
Summary0000580: offset ignored in \externalfigure
Description\starttext
\placefigure[right]{Problem: offset=20pt ignored here!}
            {\externalfigure[sample/cow.pdf]
              [scale=500, frame=on, offset=20pt,
                background=color, backgroundcolor=lightgray]}
\input knuth

\placefigure[right]{This is ok!}{\framed[offset=20pt, background=color,
    backgroundcolor=lightgray]{\externalfigure[sample/cow.pdf][scale=500]}}
\input knuth
\stoptext
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0000760)
Peter (reporter)
2011-03-25 21:22

Smaller test-file:

\starttext
\framed{\externalfigure[cow][offset=20pt]} % offset=20pt ignored here
\framed[offset=20pt]{\externalfigure[cow]} % ok
\stoptext
(0001062)
Hans Hagen (manager)
2013-04-05 19:52

that's on purpose (hard coded: overlay)
(0001090)
Peter (reporter)
2013-05-31 22:08

Hi Hans,

Could you explain please why?

TIA, Peter
(0001095)
Hans Hagen (manager)
2013-06-04 22:02

external figure is a rather basic command and framed is only part of it because of tracing and basic backgrounds for e.g. transparent images

providing backgrounds is normally done by instances of \placefigure and so

also, not enforcing overlay mode could interfere with other features (as we use the calculated width in some places and not the 'framed' dimensions); for instance in cases where we stack things (in special pdf features) we better have predictable dimensions

so ... maybe some day but it's pretty hard to predict (and avoid) side effects
unless we add some extra framed wrapper (influenced by other offset parameters) in which case one could as well wrap the thing in an external framed command)

[remark: images are not really included, but a reference node is; so, we operate in pdf coordinate space; adding offsets should then be taken into account, also in scaling and other applied operations]

- Issue History
Date Modified Username Field Change
2011-02-19 15:07 Peter New Issue
2011-03-25 21:22 Peter Note Added: 0000760
2013-04-05 19:52 Hans Hagen Note Added: 0001062
2013-04-05 19:52 Hans Hagen Status new => closed
2013-04-05 19:52 Hans Hagen Assigned To => Hans Hagen
2013-04-05 19:52 Hans Hagen Resolution open => fixed
2013-05-31 22:08 Peter Note Added: 0001090
2013-05-31 22:08 Peter Status closed => feedback
2013-05-31 22:08 Peter Resolution fixed => reopened
2013-06-04 22:02 Hans Hagen Note Added: 0001095
2017-03-27 17:15 Hans Hagen Status feedback => closed
2017-03-27 17:15 Hans Hagen Resolution reopened => fixed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker