View Issue Details

IDProjectCategoryView StatusLast Update
0000572luatexluatex bugpublic2013-12-19 14:41
ReporterPaul IsambertAssigned ToTaco 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0000572: fontloader.info returns incorrect data.
Descriptionlocal f = kpse.find_file("ChaparralPro-Semibold.otf", "opentype fonts")

-- Returns (incorrectly) "Chaparral Pro SmBd"
print(fontloader.info(f).familyname)
-- Returns (correctly) "Chaparral Pro"
print(fontloader.to_table(fontloader.open(f)).familyname)

-- Returns (incorrectly) "ChaparralPro-Semibold"
print(fontloader.info(f).fullname)
-- Returns (correctly) "Chaparral Pro Semibold"
print(fontloader.to_table(fontloader.open(f)).fullname)

Apparently, only Adobe fonts are affected, and rather erratically (e.g. Chaparral's light version is wrong too, but not the bold version, whereas Caslon's bold is wrong), and only weights (not italics).
TagsNo tags attached.

Activities

Paul Isambert

2011-02-09 09:55

reporter   ~0000735

It turns out fonloader.info reads the font's "names" table (not the top level "familyname"), and that table is a mess in Adobe's fonts, so fontloader.info correctly returns incorrect data...

Khaled Hosny

2011-02-09 10:31

developer   ~0000736

Font names is the most buggy aspect of all fonts, there are tens of redundant fields and almost no one seems to get it right.

Issue History

Date Modified Username Field Change
2011-02-09 00:20 Paul Isambert New Issue
2011-02-09 09:55 Paul Isambert Note Added: 0000735
2011-02-09 10:31 Khaled Hosny Note Added: 0000736
2011-02-10 10:36 Taco Status new => assigned
2011-02-10 10:36 Taco Assigned To => Taco
2013-12-19 14:41 Hans Hagen Status assigned => closed
2013-12-19 14:41 Hans Hagen Resolution open => fixed