View Issue Details

IDProjectCategoryView StatusLast Update
0000540luatexluatex bugpublic2011-04-12 11:06
ReporterTacoAssigned Tohhenkel 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version0.65.0 
Target VersionFixed in Version0.66.0 
Summary0000540: draftmode creates output file with zero bytes
Description\catcode`\{=1
\catcode`\}=2
\directlua{tex.enableprimitives('',{'pdfoutput'})}
\pdfoutput=1
\shipout\hbox{}
\csname @@end\endcsname\end

Result:
  LuaTeX warning: \pdfdraftmode enabled, not changing output pdf
  Transcript written on test.log.
But test.pdf is created with zero bytes.
(It does not matter if a previous test.pdf exists, it will be
overwritten.)
TagsNo tags attached.

Activities

hhenkel

2011-02-11 00:19

manager   ~0000752

duplicate of bug 548, does not appear in SVN 4073, should be solved since SVN 4061.

hhenkel

2011-04-07 22:24

manager   ~0000772

seems to work fine as well:

:~/projects/luatex/bugs/mantis-0000540$ luatex --draftmode test1
This is LuaTeX, Version beta-0.66.0-2011040722 (rev 4096)
 restricted \write18 enabled.
(./test1.tex [1] )
LuaTeX warning: \pdfdraftmode enabled, not changing output pdf
Transcript written on test1.log.

Taco

2011-04-12 11:06

administrator   ~0000815

all fixed in 0.66.0

Issue History

Date Modified Username Field Change
2010-12-26 12:12 Taco New Issue
2011-02-10 10:35 Taco Status new => assigned
2011-02-10 10:35 Taco Assigned To => hhenkel
2011-02-11 00:19 hhenkel Note Added: 0000752
2011-04-07 22:24 hhenkel Note Added: 0000772
2011-04-11 10:24 Taco Status assigned => resolved
2011-04-11 10:24 Taco Resolution open => fixed
2011-04-12 11:02 Taco Fixed in Version => 0.66.0
2011-04-12 11:06 Taco Note Added: 0000815
2011-04-12 11:06 Taco Status resolved => closed