View Issue Details

IDProjectCategoryView StatusLast Update
0000534luatexluatex bugpublic2012-12-10 12:13
ReporterphiAssigned ToTaco 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformOSMac OS XOS Version10.6.5
Product Version 
Target VersionFixed in Version 
Summary0000534: SyncTeX paths are relative to current directory
DescriptionLuaTeX sometimes writes relative paths to the SyncTeX file. These should be relative to the output directory because viewers look only in the output directory and have no idea where the input was, but are currently relative to the input directory. Another option would be to always write absolute paths.
Steps To Reproduce/tmp $ cat test.tex
\null\bye
/tmp $ luatex --synctex=1 --output-directory=b test.tex
This is LuaTeX, Version beta-0.65.0-2010120515 (rev 4022)
(./test.tex [1{/usr/local/texlive/2010/texmf-var/fonts/map/pdftex/updmap/pdftex
.map}] )</usr/local/texlive/2010/texmf-dist/fonts/type1/public/amsfonts/cm/cmr1
0.pfb>
Output written on test.pdf (1 page, 8193 bytes).
SyncTeX written on b/test.synctex.gz
Transcript written on test.log.
/tmp $ gzcat b/test.synctex.gz
SyncTeX Version:1
Input:1:./test.tex
Output:pdf
[...]
TagsNo tags attached.

Activities

phi

2011-04-14 10:13

reporter   ~0000821

See also this bug report:
http://sourceforge.net/tracker/?func=detail&aid=2872347&group_id=58056&atid=486369

Taco

2011-04-16 13:23

administrator   ~0000824

fixed by Jérome Laurens

phi

2011-05-07 15:33

reporter   ~0000834

I'm reopening this since it's still present in 0.71

Taco

2011-05-08 10:06

administrator   ~0000835

That's just because I have to do a merge from branches to trunk, right? 0.70.0 is ok?

phi

2011-05-08 23:08

reporter   ~0000836

I'll check when it's released or merged into the trunk. Sorry for the noise.

Taco

2011-05-09 14:03

administrator   ~0000837

Can you try the latest branches/0.70.x ? (rev 4255)

Taco

2011-05-09 15:37

administrator   ~0000838

should be fixed now (revs 4255-4257)

Issue History

Date Modified Username Field Change
2010-12-05 15:54 phi New Issue
2010-12-07 10:36 Taco Status new => assigned
2010-12-07 10:36 Taco Assigned To => Taco
2011-04-14 10:13 phi Note Added: 0000821
2011-04-16 13:23 Taco Note Added: 0000824
2011-04-16 13:23 Taco Status assigned => resolved
2011-04-16 13:23 Taco Resolution open => fixed
2011-05-07 15:33 phi Note Added: 0000834
2011-05-07 15:33 phi Status resolved => feedback
2011-05-07 15:33 phi Resolution fixed => reopened
2011-05-08 10:06 Taco Note Added: 0000835
2011-05-08 23:08 phi Note Added: 0000836
2011-05-08 23:08 phi Status feedback => assigned
2011-05-09 14:03 Taco Note Added: 0000837
2011-05-09 14:03 Taco Status assigned => feedback
2011-05-09 15:37 Taco Note Added: 0000838
2011-05-09 15:37 Taco Status feedback => resolved
2011-05-09 15:37 Taco Resolution reopened => fixed
2012-12-10 12:13 Taco Status resolved => closed