View Issue Details

IDProjectCategoryView StatusLast Update
0000518luatexluatex bugpublic2011-04-12 11:06
ReporterTacoAssigned ToTaco 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version0.66.0 
Summary0000518: problem with callbacks that are not supposed to return anything
DescriptionFrom Paul Isambert:

.. but is it normal that the
ligaturing and kerning callbacks go wrong when you return something, as in:

callback.register("kerning",
  function (head)
    return head
  end)

(Replace head by a number and PANIC happens.)
I know the manual says no return value, but it doesn't say they're dangerous
(although they're useless).

TagsNo tags attached.

Activities

Taco

2010-11-26 16:43

administrator   ~0000678

fixed in revision 3986. check_isnode() itself no longer does error reporting, because this function is occasionally called from outside of the interpreter proper

Taco

2010-11-26 17:20

administrator   ~0000679

that was a bad idea. revision 3988 reinstates the error checking, but with a slightly more friendly error message

Taco

2011-01-31 12:52

administrator   ~0000731

reopening, it seems the problem is that the paragraph disappears

Taco

2011-01-31 14:06

administrator   ~0000732

Should be properly fixed now

Taco

2011-04-12 11:06

administrator   ~0000818

all fixed in 0.66.0

Issue History

Date Modified Username Field Change
2010-11-18 11:36 Taco New Issue
2010-11-18 11:36 Taco Status new => assigned
2010-11-18 11:36 Taco Assigned To => Taco
2010-11-26 16:43 Taco Note Added: 0000678
2010-11-26 16:43 Taco Status assigned => resolved
2010-11-26 16:43 Taco Resolution open => fixed
2010-11-26 17:20 Taco Note Added: 0000679
2010-12-13 14:43 Taco Fixed in Version => 0.65.0
2010-12-13 14:43 Taco Status resolved => closed
2011-01-31 12:52 Taco Note Added: 0000731
2011-01-31 12:52 Taco Status closed => assigned
2011-01-31 14:06 Taco Note Added: 0000732
2011-01-31 14:06 Taco Status assigned => resolved
2011-01-31 14:06 Taco Fixed in Version 0.65.0 =>
2011-04-12 11:02 Taco Fixed in Version => 0.66.0
2011-04-12 11:06 Taco Note Added: 0000818
2011-04-12 11:06 Taco Status resolved => closed