View Issue Details

IDProjectCategoryView StatusLast Update
0000410luatexfeature requestpublic2015-10-29 15:11
ReporterTacoAssigned ToHans Hagen 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version 
Target Version0.90.0Fixed in Version0.85.0 
Summary0000410: Unicode character large operator subtypes
DescriptionFrom Aditya:
>> BTW, in both solution ?_a acts like \int\limits_a, not \int_a.
>
> In plain TeX, this is taken care by
>
> \mathchardef\intop="1352 \def\int{\intop\nolimits}
>
> Can I do the same in luatex without active characters?

No, but it is a useful extension to consider. There are internally
three types of large operators, for 'limits', 'nolimits' and
'displaylimits' and this bothers me a bit. We can't reasonably
extend the old primitives, but \Umathcharcode c.s. could be made
to accept extra values '9' .. '11' for those three types without
any compatibility problems.
Tagsmath

Activities

Taco

2010-07-28 10:47

administrator   ~0000566

Can't be done quickly because the values are passed around in cur_val which is limited to 32 bits.

Hans Hagen

2015-10-29 15:11

manager   ~0001491

redone

Issue History

Date Modified Username Field Change
2010-05-29 20:58 Taco New Issue
2010-05-29 20:58 Taco Status new => assigned
2010-05-29 20:58 Taco Assigned To => Taco
2010-07-28 10:47 Taco Note Added: 0000566
2011-04-12 11:09 Taco Target Version 0.70.0 => 0.80.0
2012-04-09 04:56 Khaled Hosny Tag Attached: math
2015-10-24 21:29 Hans Hagen Assigned To Taco => Hans Hagen
2015-10-25 11:42 Hans Hagen Target Version 0.80.0 => 0.90.0
2015-10-29 15:11 Hans Hagen Note Added: 0001491
2015-10-29 15:11 Hans Hagen Status assigned => closed
2015-10-29 15:11 Hans Hagen Resolution open => fixed
2015-10-29 15:11 Hans Hagen Fixed in Version => 0.85.0