View Issue Details

IDProjectCategoryView StatusLast Update
0000372luatexluatex bugpublic2015-10-25 11:41
ReporterTacoAssigned ToTaco 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version 
Target Version0.80.0Fixed in Version 
Summary0000372: Fix \predisplaydirection
DescriptionThe relevant bit of code has been lost in the merge of Aleph.
Additional InformationFrom Vafa:

It is an internal read/write integer, initialised by e-TeX to indicate the
direction of the last partial paragraph before a display; it is used to
control the placement of elements such as equation numbers, and can be
explictly set to affect this placement.

If you give value, say, 0 or a positive value, say 1, there is no difference
(i.e. \eqno apears on RHS, and \leqno apears on LHS) but if you give a
negative value, say -1, then \eqno will appear on LHS and \leqno will appear
on RHS.
Tagsmath

Activities

Taco

2010-04-07 16:30

administrator   ~0000526

commit 3600 is an attempt at fixing this.

luatex now initializes \predisplaydirection to -1 in \mathdir and \pardir are opposite, or to 0 in other cases.

The post-display code tests for \predisplaydirection<0. If so, it will swap
the location of the equation number. I hope this was the intended use.

Taco

2010-04-08 11:09

administrator   ~0000527

3600 introduced or highlighted other bugs, so I have taken a step back:

Let's forget about the ability to set \predisplaydirection manually for a
moment, and focus on the core functionality first.

The big question is this: should \eqno and \leqno adhere to \pardir,
to \mathdir, or simply be physical right and left without regard to
direction specifiers at all? I don't know the answer to that, so
somebody has to enlighten me.

Khaled Hosny

2010-04-08 13:56

developer   ~0000528

May preference is to treat left and right as "start of the line" and "end of the line", so that existing macro code will give the logically expected result when one switches direction (one setting equation number to the right is actually expecting it at the start of the line). If one wants right and left to be always physical right and left, then this has to be done at macro not at engine level. In an ideal world, we would use a start/end nomenclature (lets not forget about vertical typesetting, even if it isn't working properly right now), but I'm not going to demand this.

Issue History

Date Modified Username Field Change
2010-04-06 14:52 Taco New Issue
2010-04-06 14:52 Taco Status new => assigned
2010-04-06 14:52 Taco Assigned To => Taco
2010-04-07 16:30 Taco Note Added: 0000526
2010-04-07 16:30 Taco Status assigned => feedback
2010-04-08 11:09 Taco Note Added: 0000527
2010-04-08 11:09 Taco Status feedback => assigned
2010-04-08 11:09 Taco Status assigned => feedback
2010-04-08 13:56 Khaled Hosny Note Added: 0000528
2010-04-18 08:32 Taco Target Version 0.60.1 => 0.70.0
2010-04-18 08:32 Taco Additional Information Updated View Revisions
2010-04-18 08:32 Taco Status feedback => assigned
2011-04-12 11:09 Taco Target Version 0.70.0 => 0.80.0
2012-04-09 04:56 Khaled Hosny Tag Attached: math
2015-10-25 11:41 Hans Hagen Status assigned => closed
2015-10-25 11:41 Hans Hagen Resolution open => fixed