View Issue Details

IDProjectCategoryView StatusLast Update
0000371luatexluatex bugpublic2010-04-29 14:17
ReporterTacoAssigned Tohhenkel 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version0.60.0 
Target Version0.60.1Fixed in Version 
Summary0000371: local xpdf patch interferes with TL build
DescriptionThe ....NF patch in pdftoepdf.cc interferes with TL, where the accompagnying xpdf patch is not applied.

In order to complete the TL import, I've added a patched pdftoepdf to TL, with the diff listed below.
Additional Information--- source/texk/web2c/luatexdir/image/pdftoepdf.cc 2010-02-18 07:20:41.184542742 +0100
+++ /opt/tex/texlive/Build/source/texk/web2c/luatexdir/image/pdftoepdf.cc 2010-04-04 14:53:24.153913309 +0200
@@ -20,7 +20,7 @@

 static const char _svn_version[] =
     "$Id: pdftoepdf.cc 3431 2010-02-17 20:35:50Z oneiros $ "
- "$URL: http://foundry.supelec.fr/svn/luatex/trunk/source/texk/web2c/luatexdir/image/pdftoepdf.cc $";
+ "$URL: http://foundry.supelec.fr/svn/luatex/tags/beta-0.60.0/source/texk/web2c/luatexdir/image/pdftoepdf.cc $";

 #include "epdf.h"

@@ -656,12 +656,15 @@
         pdftex_warn
             ("PDF inclusion: /Resources missing. 'This practice is not recommended' (PDF Ref.)");
     } else {
+#if 0 // TEMP, waiting for XPDF patch
         resourcesNF = page->getResourcesNF();
         pdf_puts(pdf, "/Resources ");
         copyObject(pdf, pdf_doc, resourcesNF);
+#endif
     }
     // write the page /Metadata if it's there (as a stream it must be indirect)
     if (page->getMetadata() != NULL) {
+#if 0 // TEMP, waiting for XPDF patch
         metadataNF = page->getMetadataNF(); // *NF = "don't resolve indirects"
         if (!metadataNF->isRef())
             pdftex_warn("PDF inclusion: /Metadata must be indirect object");
@@ -669,6 +672,7 @@
             pdf_printf(pdf, "/Metadata %d 0 R",
                        addInObj(pdf, pdf_doc, metadataNF->getRef()));
         }
+#endif
     }
     // write the page /Group if it's there
     if (page->getGroup() != NULL) {
TagsNo tags attached.

Activities

Taco

2010-04-10 15:06

administrator   ~0000530

resolved by #3604/#3605 by Hartmut (hopefully)

hhenkel

2010-04-11 12:58

manager   ~0000531

seems to be ok after various tests (hope that's enough as FEEDBACK)

Taco

2010-04-11 13:01

administrator   ~0000532

fixed

Issue History

Date Modified Username Field Change
2010-04-04 15:33 Taco New Issue
2010-04-04 15:33 Taco Status new => assigned
2010-04-04 15:33 Taco Assigned To => hhenkel
2010-04-10 15:06 Taco Note Added: 0000530
2010-04-10 15:06 Taco Status assigned => feedback
2010-04-11 12:58 hhenkel Note Added: 0000531
2010-04-11 13:01 Taco Note Added: 0000532
2010-04-11 13:01 Taco Status feedback => assigned
2010-04-11 13:01 Taco Status assigned => resolved
2010-04-11 13:01 Taco Resolution open => fixed
2010-04-29 14:17 Taco Status resolved => closed