View Issue Details

IDProjectCategoryView StatusLast Update
0000367luatexluatex limitationpublic2015-11-10 13:23
ReporterHans HagenAssigned ToHans Hagen 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target Version0.85.0Fixed in Version0.85.0 
Summary0000367: reconsider test for valid primitive / reminder for taco and me
Descriptioncurrently the following fails:

\let\normalsometoks \sometoks

tex.set("global","normalsometoks","something")

this is a side effect of a test for the name being a primitive

there is probably a good reason why we needed this in the early days but we can now reconsider it
Additional Informationrelevant piece of code:

if (lua_isstring(L, (i - 1))) {
        st = lua_tolstring(L, (i - 1), &k);
        texstr = maketexlstring(st, k);
        if (is_primitive(texstr)) {
TagsNo tags attached.

Relationships

related to 0000366 closedTaco tex.pdfoutput=1 creates dvi 

Activities

Taco

2010-04-01 17:01

administrator   ~0000518

This is related to 366 because of the current inability to change the equivalence table from lua.

Hans Hagen

2015-11-10 13:23

manager   ~0001531

we can now access them with tex.[set|get][dimen|count|skip|muskip]

Issue History

Date Modified Username Field Change
2010-04-01 16:56 Hans Hagen New Issue
2010-04-01 17:01 Taco Relationship added related to 0000366
2010-04-01 17:01 Taco Note Added: 0000518
2011-04-12 11:09 Taco Target Version 0.70.0 => 0.80.0
2015-10-24 21:44 Hans Hagen Assigned To => Hans Hagen
2015-10-24 21:44 Hans Hagen Status new => assigned
2015-10-25 11:40 Hans Hagen Target Version 0.80.0 => 0.85.0
2015-11-10 13:23 Hans Hagen Note Added: 0001531
2015-11-10 13:23 Hans Hagen Status assigned => closed
2015-11-10 13:23 Hans Hagen Resolution open => fixed
2015-11-10 13:23 Hans Hagen Fixed in Version => 0.85.0