View Issue Details

IDProjectCategoryView StatusLast Update
0000282luatexluatex limitationpublic2009-12-18 11:07
ReporteroneirosAssigned ToTaco 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target Version0.47.0Fixed in Version0.47.0 
Summary0000282: Solve problem with pdf inclusion and maximum number of open files
DescriptionCurrently luatex when including pdfs works in two phases:
- first (\pdfximage) the pdf is opened and some information (size
  etc.) is extracted
- later when writing the page the pdf is read and copied to the output
  file
Since the pdf is kept open during the whole process, the number of
pdfs that can be included this way is limited by the number of files a
program can open at the same time (typically 1024). The work-around
for this is to make \pdfximage \immediate: luatex then writes out the
output file immediately and closes the pdf.

If we want to keep the two-phase approach, I propose a different way:
Get some information about the pdf that uniquely identify it
(timestamp, size, id, md5?) from the pdf in the first phase and close
it. Later open it again when needed and check the information from the
first phase - and raise an error when the file has vanished or changed.
TagsNo tags attached.

Relationships

related to 0000294 closedTaco corrupt pdf file due to no check for inclusion change 

Activities

Taco

2009-11-09 15:09

administrator   ~0000330

Just storing the modification time and size should be enough, I think.

Taco

2009-12-01 11:01

administrator   ~0000358

Commit #3202 has a preliminary patch for this bug. Martin, can you please test?

Taco

2009-12-10 11:02

administrator   ~0000371

Assuming this is fixed

Issue History

Date Modified Username Field Change
2009-10-20 11:29 oneiros New Issue
2009-11-09 15:09 Taco Note Added: 0000330
2009-11-18 12:13 Taco Relationship added related to 0000294
2009-12-01 10:08 Taco Status new => assigned
2009-12-01 10:08 Taco Assigned To => Taco
2009-12-01 11:01 Taco Note Added: 0000358
2009-12-01 11:01 Taco Status assigned => feedback
2009-12-02 14:24 Taco Target Version => 0.50.0
2009-12-10 11:02 Taco Status feedback => resolved
2009-12-10 11:02 Taco Resolution open => fixed
2009-12-10 11:02 Taco Note Added: 0000371
2009-12-18 11:06 Taco Target Version 0.50.0 => 0.47.0
2009-12-18 11:06 Taco Fixed in Version => 0.47.0
2009-12-18 11:07 Taco Status resolved => closed