View Issue Details

IDProjectCategoryView StatusLast Update
0000276luatexluatex bugpublic2009-11-18 16:55
ReporterTacoAssigned Tohhenkel 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.43.0 
Target Version0.50.0Fixed in Version0.45.0 
Summary0000276: context fails to load a pdf image file
DescriptionFrom Zdenek (zs):

Hi all,

I found that using latest I cannot get readable pdf file from folowing minimal code.

This is LuaTeX, Version beta-0.43.0-2009081914
ConTeXt ver: 2009.10.02 13:14 MKIV fmt: 2009.10.5 int: english/english
..... "context minimal" gives me corrupted pdf.
..... "texexec -pdf minimal" works OK.


This is LuaTeX, Version beta-0.40.6-2009062513
ConTeXt ver: 2009.06.14 21:01 MKIV fmt: 2009.7.15 int: english/english
..... everything works OK.


\starttext
\placefigure[here,force][]{none}{\externalfigure[example.pdf][width=10cm]}
\stoptext

The "example.pdf" is attached.

TagsNo tags attached.

Activities

2009-10-06 09:20

 

example.pdf (3,270 bytes)

Taco

2009-10-06 09:21

administrator   ~0000272

From Taco:
Here ConTeXt ver: 2009.09.25 12:15 MKIV fmt: 2009.9.25, as well as
ConTeXt ver: 2009.09.28 09:02 MKIV fmt: 2009.10.5 with luatex 0.43
both result in an invalid page catalog with compression on (default):

  xpdf ex.pdf
  Error: Catalog object is wrong type (null)
  Error: Couldn't read page catalog

and with just a broken xref table with object compression off
(\nopdfcompression or \pdfobjcompresslevel=0):

  xpdf ex.pdf
  Error: PDF file is damaged - attempting to reconstruct xref table...

Somehow this is related to the example.pdf, because using cow.pdf works
just fine.

Taco

2009-10-06 09:21

administrator   ~0000273

From Martin:

example.pdf has a /Group. And it works here in pdfTeX 1.50 & LaTeX.
Can LuaTeX handle pdf inclusion with transparency groups?

Taco

2009-10-06 09:21

administrator   ~0000274

From Zdenek:

> example.pdf has a /Group. And it works here in pdfTeX 1.50 & LaTeX.
> Can LuaTeX handle pdf inclusion with transparency groups?

It was formerly able to handle it seamlessly for very long time, only recent version cannot.

Taco

2009-11-03 16:59

administrator   ~0000316

This is bug is fixed by commit 3089.

Issue History

Date Modified Username Field Change
2009-10-06 09:20 Taco New Issue
2009-10-06 09:20 Taco File Added: example.pdf
2009-10-06 09:21 Taco Note Added: 0000272
2009-10-06 09:21 Taco Note Added: 0000273
2009-10-06 09:21 Taco Note Added: 0000274
2009-10-08 14:24 Taco Status new => assigned
2009-10-08 14:24 Taco Assigned To => hhenkel
2009-11-03 16:59 Taco Status assigned => resolved
2009-11-03 16:59 Taco Resolution open => fixed
2009-11-03 16:59 Taco Note Added: 0000316
2009-11-18 16:54 Taco Fixed in Version => 0.45.0
2009-11-18 16:55 Taco Status resolved => closed