View Issue Details

IDProjectCategoryView StatusLast Update
0000026luatexluatex bugpublic2008-04-17 17:41
ReporterarthurAssigned To 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionno change required 
Product Version0.25.1 
Target VersionFixed in Version 
Summary0000026: Wrong calculation of some values
DescriptionThe attached zip is an extract of the Gregorio system for typesetting gregorian chant scores (http://home.gna.org/gregorio/). The bug happens with the file test.tex (plain LuaTeX), which includes the rather long gregoriotex.tex: it simply sets a single note on the score, but if we uncomment line 249 of gregoriotex (a simple \showthe command), the result is different.

In results/ I've attached the two possible results, when uncommenting the \showte command (test-showthe.pdf) and commenting it out (test-commented.pdf).
Additional InformationSorry I can't be more precise, but the bug seems to be quite real, and independent of the architecture or the LuaTeX version. It has been reported to me by √Člie Roux (elie.roux@enst-bretagne.fr), the Gregorio author.
TagsNo tags attached.

Activities

2008-04-13 03:50

 

wrong-value.zip (720,947 bytes)

arthur

2008-04-13 21:00

developer   ~0000014

√Člie just confirmed that the intended result is the one with the \showthe commend. Incidentally, replacing that command with something unrelated to calculations, like a \message{Hello world} gives the same (correct) result.

eroux

2008-04-16 17:56

reporter   ~0000015

I've just discovered that this bug is not only in omega, aleph and luatex, but also in tex...

http://norgz.info/bug.zip << here are two tex files to reproduce the bug : gregorio-good and gregorio-bad only differ in one \showthe, and yet the result is different...

Where can I bugreport that ? Could someone help me fixing it ?

Thank you,
--
Elie

Taco

2008-04-17 17:39

administrator   ~0000016

This:

  \global\isonaline=\number 0\iftrue1\fi

assigns 1 because the \if... is still part of the assignment.

Removing the % at the end of line 172

  \global\isonaline=\number 0%

fixes the wrong output.

Best wishes,
Taco

Issue History

Date Modified Username Field Change
2008-04-13 03:50 arthur New Issue
2008-04-13 03:50 arthur File Added: wrong-value.zip
2008-04-13 21:00 arthur Note Added: 0000014
2008-04-16 17:56 eroux Note Added: 0000015
2008-04-17 17:39 Taco Note Added: 0000016
2008-04-17 17:41 Taco Status new => closed
2008-04-17 17:41 Taco Resolution open => no change required