View Issue Details

IDProjectCategoryView StatusLast Update
0000254luatexluatex bugpublic2009-08-19 10:47
ReporterDenisGAssigned ToTaco 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version0.43.0 
Summary0000254: Ecclesiastic Latin hyphenation - accented vowels cause hyphenation to fail
DescriptionThe attached zip file contains 3 cases - test3-a, test3-b and test3-c. Each of the source files contain 3 versions of the same Latin text. The first is the plain Latin which hyphenates perfectly in all 3 files. The second is the same text but this time accented in the manner commonly used in liturgic books - the accent marks the emphasized syllable to facilitate public reading - this text does not hyphenate well in the first and third file. The third version is the same accented text but with discretionary hyphenation points (\-) entered at all legitimate places. This text also hyphenates perfectly in all three files.

The first file (test3-a) is processed with pdflualatex, the second file (test3-b) is processed using pdflatex with the addition of a usepackage utf8 inputenc and the third (test3-c) processed with pdflualatex with usepackage utf8 luainputenc. I have to admit I am not sure I completely understand the potential role of luainputenc...

It appears to me that the hyphenation process is failing in pdflualatex. Obviously having to enter all possible hyphenation points in advance makes it prohibitive. pdflatex produces the expected results. As it is my understanding that luatex is ment to replace or at the very least be equivalent to tex. I thought you would like to know of this experiment.
TagsNo tags attached.

Activities

2009-07-25 18:18

 

examples.zip (102,439 bytes)

Taco

2009-07-27 10:38

administrator   ~0000240

I just tried this file myself, and I can now almost see why it fails.

The problem is the word scienti'aeque. There is no prebuilt \'\ae in Unicode, so the result is the expansion of the word is "scienti\accent 1\ae que", and this
is what is actually causing the problem. I'll dig further

Taco

2009-07-30 10:55

administrator   ~0000242

Should be fixed by 2932. This allows accent-generated kerns to end words,
and that in turn will allow hyphenation if the "scienti" part of the word,
just like in pdftex.

Issue History

Date Modified Username Field Change
2009-07-25 18:18 DenisG New Issue
2009-07-25 18:18 DenisG File Added: examples.zip
2009-07-27 10:38 Taco Note Added: 0000240
2009-07-27 10:38 Taco Status new => assigned
2009-07-27 10:38 Taco Assigned To => Taco
2009-07-30 10:55 Taco Status assigned => resolved
2009-07-30 10:55 Taco Resolution open => fixed
2009-07-30 10:55 Taco Note Added: 0000242
2009-08-19 10:46 Taco Fixed in Version => 0.43.0
2009-08-19 10:47 Taco Status resolved => closed