View Issue Details

IDProjectCategoryView StatusLast Update
0000250luatexluatex bugpublic2012-04-09 05:05
ReporterTacoAssigned ToTaco 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target Version0.80.0Fixed in Version0.70.0 
Summary0000250: misplaced math (TLT) displays in TRT mode
DescriptionFrom Vafa:

The follwing tex file and its pdf output shows a bug which has not been fixed. It simply in RTL mode shifts display formula to the left instead placing it at the center. This has been tested with the luatex n TeXLive 2009.
Tagsmath

Activities

2009-07-16 09:30

 

test-bug.tex (113 bytes)

2009-07-16 09:30

 

test-bug.pdf (51,733 bytes)

Taco

2009-07-16 12:54

administrator   ~0000237

This will take a while, this is a fairly tricky (because the outer text direction is hidden on the save stack when then shifts for the display box are calculated)

Taco

2009-07-29 17:58

administrator   ~0000241

Should be fixed by #2931

Taco

2009-07-31 09:21

administrator   ~0000249

#2938 has a better fix (based on \pardir, not \textdir)

2009-07-31 09:22

 

test-mdisplay.tex (2,235 bytes)

Taco

2010-11-11 08:25

administrator   ~0000652

This bug (or something close to it) resurfaced in 0.62.0.

Vafa's test:


\input bidi
\pagedir TRT\pardir TRT\bodydir TRT\textdir TRT
$$1+2=3\eqno(1)$$
\end

vafakhlgh

2010-11-11 10:21

reporter   ~0000653

I am pretty sure that this is a side effect of fixing \predisplaydirection primitive. Because as soon as you announced that \predisplaydirection is working, this bug again appeared.

Khaled Hosny

2011-04-15 13:20

developer   ~0000822

Taco, if it really related to \predisplaydirection fix, then I'd rather revert that fix; \predisplaydirection is a pretty obscure feature and having it broken for another release is better than breaking all TLT displays in TRT text (which is the most common RTL setup).

Taco

2011-04-16 15:31

administrator   ~0000825

Hi,

I took a more serious approach and tried to fix the proplem properly without touching the \predisplaydirection stuff. The result is committed as #4170 in branches/0.70.x, and it appears to do the right thing in all cases now

Issue History

Date Modified Username Field Change
2009-07-16 09:30 Taco New Issue
2009-07-16 09:30 Taco File Added: test-bug.tex
2009-07-16 09:30 Taco File Added: test-bug.pdf
2009-07-16 11:15 Taco Status new => assigned
2009-07-16 11:15 Taco Assigned To => Taco
2009-07-16 11:16 Taco Target Version => 0.50.0
2009-07-16 12:54 Taco Note Added: 0000237
2009-07-29 17:58 Taco Status assigned => resolved
2009-07-29 17:58 Taco Resolution open => fixed
2009-07-29 17:58 Taco Note Added: 0000241
2009-07-31 09:21 Taco Note Added: 0000249
2009-07-31 09:22 Taco File Added: test-mdisplay.tex
2009-08-19 10:46 Taco Fixed in Version => 0.43.0
2009-08-19 10:47 Taco Status resolved => closed
2010-11-11 08:25 Taco Note Added: 0000652
2010-11-11 08:25 Taco Status closed => new
2010-11-11 08:25 Taco Status new => assigned
2010-11-11 10:21 vafakhlgh Note Added: 0000653
2011-04-12 11:09 Taco Target Version 0.50.0 => 0.80.0
2011-04-15 13:20 Khaled Hosny Note Added: 0000822
2011-04-16 15:31 Taco Note Added: 0000825
2011-04-16 15:31 Taco Status assigned => resolved
2011-04-16 15:31 Taco Fixed in Version 0.43.0 => 0.70.0
2011-05-10 08:56 Taco Status resolved => closed
2012-04-09 05:05 Khaled Hosny Tag Attached: math