View Issue Details

IDProjectCategoryView StatusLast Update
0000248luatexfeature requestpublic2012-04-09 05:10
ReporterHans HagenAssigned ToTaco 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version0.43.0 
Summary0000248: flag in tfm table that inhibits math
Descriptionwhen passing a large tfm table to luatex (e.g. cjk fonts) that has no math, at the tex end still checking needs to be done for a bunch of math related keys; as it is known at the lua end that a table has no math (or simply because we want to use the text part of a math font only) we can have a tfmtable.ignoremath key

this can speed up cjk fontloading
Steps To Reproducecan be tested in mkiv
Tagsmath

Activities

Taco

2009-07-16 09:26

administrator   ~0000231

this is done in trunk already: <font>.nomath = true disables loading of math parameters (not in the manual yet)

Issue History

Date Modified Username Field Change
2009-07-08 11:40 Hans Hagen New Issue
2009-07-16 09:26 Taco Status new => resolved
2009-07-16 09:26 Taco Resolution open => fixed
2009-07-16 09:26 Taco Assigned To => Taco
2009-07-16 09:26 Taco Note Added: 0000231
2009-08-19 10:46 Taco Fixed in Version => 0.43.0
2009-08-19 10:47 Taco Status resolved => closed
2012-04-09 05:10 Khaled Hosny Tag Attached: math