View Issue Details

IDProjectCategoryView StatusLast Update
0000024luatexluatex limitationpublic2009-12-18 11:07
ReporterTacoAssigned Tohhenkel 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version 
Target Version0.47.0Fixed in Version0.47.0 
Summary0000024: support font matrix manipulation for non-type1 fonts
DescriptionFor Type1 fonts, there can be maplines such as this:

  ptmbo8r NimbusRomNo9L-Medi ".167 SlantFont" <8r.enc <utmb8a.pfb

There is currently no way to do the same for TTF or OTF fonts
TagsNo tags attached.

Activities

Taco

2009-12-01 14:32

administrator   ~0000362

Probably all of this trickery should be done via /Tm, also for Type1

hhenkel

2009-12-08 23:56

manager   ~0000370

i guess SlantFont should not have been in a mapfile/line at all (to be deprecated), as slant has nothing to do with the connection/mapping between tfm name (tfm metrics) and font file name (font metrics). it seems to be cleaner (and easier) to do this as font definition, e. g., \font\cmrsl cmr10 at 10pt slanted 1200, then one can use the same tfm font in different slants by changing the TM, also consistent for all font types. One could even disconnect slant from the font completely, adding a \slantfont primitive? But this separation might make font switching tedious. In any case one would get rid of these specially crafted exotic PS font names "*-Slant_i", which are complicating font replacement from embedded PDF files.

hhenkel

2009-12-10 23:39

manager   ~0000374

should be fixed in SVN 3246. mapfile interface unchanged (note 0000370 above not implemented).

Issue History

Date Modified Username Field Change
2008-03-20 15:23 Taco New Issue
2008-03-21 13:58 Taco Projection none => minor fix
2008-05-21 15:04 Hans Hagen Assigned To => hhenkel
2008-05-21 15:04 Hans Hagen Status new => assigned
2008-09-30 11:51 Taco Target Version 0.30.0 => 0.40.0
2009-04-11 12:32 Taco Target Version 0.40.0 => 0.50.0
2009-12-01 14:32 Taco Note Added: 0000362
2009-12-08 23:56 hhenkel Note Added: 0000370
2009-12-10 23:39 hhenkel Note Added: 0000374
2009-12-10 23:42 hhenkel Status assigned => resolved
2009-12-10 23:42 hhenkel Resolution open => fixed
2009-12-18 11:06 Taco Target Version 0.50.0 => 0.47.0
2009-12-18 11:06 Taco Fixed in Version => 0.47.0
2009-12-18 11:07 Taco Status resolved => closed