View Issue Details

IDProjectCategoryView StatusLast Update
0000023luatexluatex bugpublic2008-09-30 11:49
ReporterTacoAssigned ToTaco 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target Version0.30.0Fixed in Version0.30.0 
Summary0000023: conflict between tex.sprint and \input catcodes
DescriptionWith the lua code

  tex.sprint(<catcode table>, "\input x.tex ")

the first line of x.tex will also be read using <catcode table>.
Additional InformationThe problem here is that the internal variable that keeps track of "specialness" of the catcode table for lua-created input lines is cleared only at the end of the line, and that condition is not triggered by tex.sprint.

A quick and simple solution is not possible because a less obvious problem is that that "specialness" should really be part of the input_stack structure.
Otherwise in
  
   aa\directlua{tex.sprint(<catcode table>, "\input x.tex ")}bb

the catcode table will be reset before 'bb'.
TagsNo tags attached.

Activities

Hans Hagen

2008-09-29 12:54

manager   ~0000065

\startluacode
io.savedata("crap.tex","$ oeps $\n\\starttyping\n% oeps oeps\n\\stoptyping")
\stopluacode

\starttext

\def\test
  {\bgroup
   \setcatcodetable\xmlcatcodes
   \ctxlua{tex.sprint(tex.ctxcatcodes,"\\input crap.tex ")}%
   \egroup}

\test

\stoptext

Taco

2008-09-29 15:09

administrator   ~0000066

fixed by #1517

Issue History

Date Modified Username Field Change
2008-03-17 13:58 Taco New Issue
2008-03-17 13:58 Taco Status new => assigned
2008-03-17 13:58 Taco Assigned To => Taco
2008-03-21 13:55 Taco Target Version 0.25.1 => 0.30.0
2008-09-29 12:54 Hans Hagen Note Added: 0000065
2008-09-29 15:09 Taco Status assigned => resolved
2008-09-29 15:09 Taco Fixed in Version => 0.30.0
2008-09-29 15:09 Taco Resolution open => fixed
2008-09-29 15:09 Taco Note Added: 0000066
2008-09-30 11:49 Taco Status resolved => closed