View Issue Details

IDProjectCategoryView StatusLast Update
0000021luatexluatex bugpublic2008-02-20 11:13
ReporterTacoAssigned ToTaco 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version0.22.0 
Target Version0.22.1Fixed in Version0.22.1 
Summary0000021: Assertion with font expansion
DescriptionFrom Jonathan Sauer:

while using font expansion I get an assertion at the end of the
following PlainTeX document:

------------------------------------------------------------------------

\pdfoutput1
\pdffontexpand\tenrm 30 10 10 autoexpand\relax
\pdfadjustspacing2 % A

\tenrm
\def\ldots{...}

\hsize=10cm

Die Strassenbahn ratterte ueber eine Weiche, weshalb die beiden Maedchen
wie auch die restlichen Passagiere in der halbvollen Bahn
durchgeschuettelt wurden. ``Ansonsten~\ldots'' Ataami hob die
Schultern. ``Der Schwarzfahrer hat ja nicht ihn angegriffen oder so.''
\bye
TagsNo tags attached.

Activities

Taco

2008-02-20 11:13

administrator   ~0000010

This was because do_subst_font() was sometimes called on an already expanded object, causing it to attempt to expand an expanded font.

Fixed in trunk

Issue History

Date Modified Username Field Change
2008-02-20 11:12 Taco New Issue
2008-02-20 11:12 Taco Status new => assigned
2008-02-20 11:12 Taco Assigned To => Taco
2008-02-20 11:13 Taco Note Added: 0000010
2008-02-20 11:13 Taco Status assigned => closed
2008-02-20 11:13 Taco Resolution open => fixed
2008-02-20 11:13 Taco Fixed in Version => 0.22.1