View Issue Details

IDProjectCategoryView StatusLast Update
0000206luatexluatex bugpublic2012-04-09 05:09
ReporterTacoAssigned ToTaco 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version0.39.0 
Target Version0.47.0Fixed in Version0.47.0 
Summary0000206: \atopwidthdelims does not work for OT MATH fonts
DescriptionTomas Kisela wrote:
> >
> > Binomial coefficients:
> > The brackets stay small (usual size like in plain text), here's my code:
> > \starttext
> > \startformula
> > {a\choose b}
> > \stopformula
> > \stoptext

This is currently an issue with opentype math fonts: luatex doesn't know
what the values of \Umathfractiondelsize should be.

For a workaround: explicitly setting

 \Umathfractiondelsize\textstyle = 12.12pt
 \Umathfractiondelsize\displaystyle = 28.68pt

will set up values that closely mimic "cmsy10 at 12pt"

Ulrik Vieth (who is in CC) proposes to use DelimitedSubFormulaMinHeight
in non-display modes, but the DelimitedSubFormulaMinHeight in Cambria
Math is 3000/2048 * <atsize> == 17.58pt, which also doesn't seem right.

Since Hans converts everything to OpenType MathConstants format,
perhaps I should just add two more named entries to be parsed
in the MathConstants table?
Tagsmath

Activities

Taco

2009-12-02 14:57

administrator   ~0000368

Commit #3214 adds two new MATH parameters

MathConstants.FractionDelimiterSize
MathConstants.FractionDelimiterDisplayStyleSize

Issue History

Date Modified Username Field Change
2009-04-16 11:19 Taco New Issue
2009-04-16 11:19 Taco Status new => assigned
2009-04-16 11:19 Taco Assigned To => Taco
2009-04-22 13:09 Taco Target Version 0.40.0 =>
2009-12-02 14:40 Taco Target Version => 0.50.0
2009-12-02 14:57 Taco Status assigned => resolved
2009-12-02 14:57 Taco Resolution open => fixed
2009-12-02 14:57 Taco Note Added: 0000368
2009-12-18 11:06 Taco Target Version 0.50.0 => 0.47.0
2009-12-18 11:06 Taco Fixed in Version => 0.47.0
2009-12-18 11:07 Taco Status resolved => closed
2012-04-09 05:09 Khaled Hosny Tag Attached: math