View Issue Details

IDProjectCategoryView StatusLast Update
0000020luatexluatex bugpublic2008-02-20 11:11
ReporterTacoAssigned ToTaco 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version0.22.0 
Target Version0.22.1Fixed in Version0.22.1 
Summary0000020: Abort if '--progname' is used but --fmt isnt
DescriptionForn Jonathan Sauer:

Furthermore, I tried to set the program name using '--progname' and
got:

----------------------------------------------------------------------

jonathansauer$ luatex --progname=luatex kpseTest
Abort trap

---------------------------------------------------------------------

The reason for this seems to lie in file 'luainit.c', function
'init_kpse', where 'dump_name' is only initialized with the name of
the executable when 'user_progname' has not been set (and if LuaTeX is
not in IniTeX mode) [BTW: The casts to 'string' in the function are
not necessary (anymore?)].
TagsNo tags attached.

Activities

Taco

2008-02-20 11:11

administrator   ~0000009

fix is in trunk

Issue History

Date Modified Username Field Change
2008-02-20 11:10 Taco New Issue
2008-02-20 11:10 Taco Status new => assigned
2008-02-20 11:10 Taco Assigned To => Taco
2008-02-20 11:11 Taco Note Added: 0000009
2008-02-20 11:11 Taco Status assigned => closed
2008-02-20 11:11 Taco Resolution open => fixed
2008-02-20 11:11 Taco Fixed in Version => 0.22.1