View Issue Details

IDProjectCategoryView StatusLast Update
0000161luatexluatex bugpublic2009-03-23 11:01
ReporterolliAssigned ToTaco 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version0.31.3 
Target VersionFixed in Version0.36.0 
Summary0000161: \outer has no effect
DescriptionThings like
\outer\def\foo{moo!} \def\bar{\foo}
don't throw an error (which they should, cf. TeXbook p. 206).

Moreover, LuaTeX allows using \input in an \edef (which is very much the same as allowing an \outer\def'ed).

 olli
TagsNo tags attached.

Activities

Taco

2009-02-24 14:44

administrator   ~0000110

This is not a bug but a feature

Taco

2009-03-16 17:39

administrator   ~0000118

Reopened because it is nicer to do this via a to-be-written \supppressoutererror than to ignore it always

Taco

2009-03-21 11:29

administrator   ~0000123

#2074 restores \outer and adds a new primitive \suppressoutererror to get the 'old' luatex behaviour

Issue History

Date Modified Username Field Change
2009-02-18 21:25 olli New Issue
2009-02-24 14:44 Taco Status new => closed
2009-02-24 14:44 Taco Note Added: 0000110
2009-02-24 14:44 Taco Resolution open => won't fix
2009-03-16 17:39 Taco Note Added: 0000118
2009-03-16 17:39 Taco Assigned To => Taco
2009-03-16 17:39 Taco Status closed => assigned
2009-03-21 11:29 Taco Status assigned => resolved
2009-03-21 11:29 Taco Fixed in Version => 0.36.0
2009-03-21 11:29 Taco Resolution won't fix => fixed
2009-03-21 11:29 Taco Note Added: 0000123
2009-03-23 11:01 Taco Status resolved => closed