View Issue Details

IDProjectCategoryView StatusLast Update
0000154luatexluatex bugpublic2009-04-10 12:37
ReporterTacoAssigned ToTaco 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version 
Target Version0.38.0Fixed in Version0.38.0 
Summary0000154: Empty \local..boxes are creating problems
DescriptionAttached is a bug test from Elie Roux illustrating the problem,
which is that \localleftbox {} results in an empty \hbox{} being added to each line.

Elie wrote:
I have finally found the bug I was tracking in Gregorio for some time... Here is an example where putting empty boxes does not lead to a strange behaviour, but to a really buggy behaviour: If an empty \localleftbox is set with attribute 1, and after that we set the attribute to -1, the lines after the first will still have the attribute set to 1, because the empty box will set it... It is I think extremely confusing, and it's a bug that is difficult to track (even if now that I have the solution it will be a one-liner patch to fix it). So I insist, I think that removing the nodes will be much better, because this kind of behaviour will certainly appear with a lot of styles using \localleftbox.
Additional InformationIn the implementation it will be best to intercept the empty box at definition time. If there is no contents, it can revert back to voidness right there.
TagsNo tags attached.

Activities

2009-02-02 23:25

 

bug-l.zip (761 bytes)

Taco

2009-04-09 19:42

administrator   ~0000150

patched by #2234

Issue History

Date Modified Username Field Change
2009-02-02 23:25 Taco New Issue
2009-02-02 23:25 Taco File Added: bug-l.zip
2009-02-02 23:25 Taco Status new => assigned
2009-02-02 23:25 Taco Assigned To => Taco
2009-02-24 15:00 Taco Target Version => 0.40.0
2009-04-09 19:42 Taco Status assigned => resolved
2009-04-09 19:42 Taco Resolution open => fixed
2009-04-09 19:42 Taco Note Added: 0000150
2009-04-10 12:36 Taco Fixed in Version => 0.38.0
2009-04-10 12:36 Taco Target Version 0.40.0 => 0.38.0
2009-04-10 12:37 Taco Status resolved => closed