View Issue Details

IDProjectCategoryView StatusLast Update
0000137MetaPostbugpublic2009-05-11 11:12
Reporterluigi scarsoAssigned ToTaco 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target Version1.200Fixed in Version 
Summary0000137: Incorrect svg ouput
DescriptionThis example from ex_mp.zip gives incorrect svg outoput

% Examples for MetaPost doc, by John Hobby. Public domain.

outputformat := "svg";
filenametemplate "%j-%c.svg";

input boxes


\beginfig(6);
fill unitsquare xscaled 1.1in yscaled .7in withcolor .9white;
boxit(currentpicture);
dx = dy = .25in;
clearit; drawboxed();
forsuffixes $=n,c: makelabel.top(str $, $); endfor
makelabel.bot("s",s);
forsuffixes $=ne,e,se: makelabel.rt(str $, $); endfor
forsuffixes $=nw,w,sw: makelabel.lft(str $, $); endfor
pickup pencircle scaled .3bp;
vardef larrow@#(expr a, da, s) =
  drawdblarrow a..a+da; label@#(s,a+.5da); enddef;
larrow.rt(n, (0,-dy), "dy");
larrow.rt(s, (0,dy), "dy");
larrow.top(e, (-dx,0), "dx");
larrow.top(w, (dx,0), "dx");
endfig;


end
TagsNo tags attached.

Activities

Taco

2008-12-10 17:26

administrator   ~0000087

It looks like this is fixed in the metapost repository trunk now.
Can you check as well please?

luigi scarso

2008-12-10 20:06

manager   ~0000088

ok fixed.

Taco

2008-12-11 09:22

administrator   ~0000090

fixed in repository

Issue History

Date Modified Username Field Change
2008-12-06 18:14 luigi scarso New Issue
2008-12-10 17:26 Taco Note Added: 0000087
2008-12-10 17:26 Taco Status new => assigned
2008-12-10 17:26 Taco Assigned To => Taco
2008-12-10 20:06 luigi scarso Note Added: 0000088
2008-12-11 09:22 Taco Status assigned => resolved
2008-12-11 09:22 Taco Resolution open => fixed
2008-12-11 09:22 Taco Note Added: 0000090
2009-01-02 17:35 Taco Project @3@ => MetaPost
2009-03-26 10:51 Taco Category mplib bug => bug
2009-04-20 13:14 Taco Target Version => 1.150
2009-04-21 19:07 Taco Target Version 1.150 => 1.200
2009-05-11 11:12 Taco Status resolved => closed