View Issue Details

IDProjectCategoryView StatusLast Update
0001021contextbug reportpublic2020-07-21 17:24
ReporterjemmybuttonAssigned ToHans Hagen 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0001021: pens in metapost stop working after clipping is used
DescriptionWith ConTeXt ver: 2020.03.10 14:44 MKIV beta fmt: 2020.7.20 with mplib v2.20.5 the following happens:
After a clipping mask is used, pens stop changing thicknesses.
This didn't happen in earlier versions of ConTeXt, nor does it happen with LuaLaTeX with the same mplib.
Steps To Reproduce\starttext
\startMPcode
picture p;
p := image(draw (0, 0)--(1cm, 1cm) withpen pencircle scaled 1cm;);
clip p to (unitsquare shifted (-1/2, -1/2) scaled 10 cm); %this one
draw p;
draw (0, 0)--(-1cm, 1cm) withpen pencircle scaled 1cm;
\stopMPcode
\stoptext

produces a picture with one thick line and one thin line (bug.png), while

\starttext
\startMPcode
picture p;
p := image(draw (0, 0)--(1cm, 1cm) withpen pencircle scaled 1cm;);
draw p;
draw (0, 0)--(-1cm, 1cm) withpen pencircle scaled 1cm;
\stopMPcode
\stoptext

produces two thick lines as intended (nobug.png)
TagsNo tags attached.

Activities

jemmybutton

2020-07-21 01:16

reporter  

bug.png (2,482 bytes)
bug.png (2,482 bytes)
nobug.png (2,486 bytes)
nobug.png (2,486 bytes)

Hans Hagen

2020-07-21 17:24

manager   ~0001730

fixed in next version (of context)

best report this to the context list or in the context tracker because usually something like this doesn't relate to luatex (where mplib doesn't change) or lualatex / plain (which uses different code)

Hans Hagen

2020-07-21 17:24

manager   ~0001731

fixed in context, no luatex change needed

Issue History

Date Modified Username Field Change
2020-07-21 01:16 jemmybutton New Issue
2020-07-21 01:16 jemmybutton File Added: bug.png
2020-07-21 01:16 jemmybutton File Added: nobug.png
2020-07-21 17:24 Hans Hagen Note Added: 0001730
2020-07-21 17:24 Hans Hagen Assigned To => Hans Hagen
2020-07-21 17:24 Hans Hagen Status new => closed
2020-07-21 17:24 Hans Hagen Resolution open => fixed
2020-07-21 17:24 Hans Hagen Note Added: 0001731