View Issue Details

IDProjectCategoryView StatusLast Update
0000102luatexluatex bugpublic2008-11-24 15:42
ReporterTacoAssigned ToTaco 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version0.30.3 
Summary0000102: Hyphenation errors
Description
Luatex hyhenates german words that end with -ich incorrectly (between the i and the c.)
Steps To ReproduceSee attached test files for demonstration.

Even more obvious "bei-ge", the pattern for that is ".bei6ge.", so it should not hyphenate at all.
Additional InformationIt seems there is (at least) a problem with all patterns that are
supposed to end a word. For example, the "4ch." that is supposed to
prevent i-ch appears to be ignored (at first glance, it looks like it
is interpreted as "c4h." and etc. for all others with a trailing ".")
TagsNo tags attached.

Activities

2008-11-23 11:54

 

hyph-test-de.zip (46,832 bytes)

Taco

2008-11-24 15:42

administrator   ~0000083

There were a few bugs cooperating to produce this bug.

See the svn log remarks of #1576-#1578

Issue History

Date Modified Username Field Change
2008-11-23 11:54 Taco New Issue
2008-11-23 11:54 Taco Status new => assigned
2008-11-23 11:54 Taco Assigned To => Taco
2008-11-23 11:54 Taco File Added: hyph-test-de.zip
2008-11-24 15:42 Taco Status assigned => closed
2008-11-24 15:42 Taco Note Added: 0000083
2008-11-24 15:42 Taco Resolution open => fixed
2008-11-24 15:42 Taco Fixed in Version => 0.30.3