View Issue Details

IDProjectCategoryView StatusLast Update
0001007luatexluatex bugpublic2019-06-14 12:45
Reporterat7howardAssigned ToHans Hagen 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionno change required 
PlatformtexworksOSwindowsOS Version10
Product Version1.0.0 
Target VersionFixed in Version 
Summary0001007: Math symbols outside math environment improperly size in Lua(La)tex 1.10.0
Descriptionmath symbols not in the math environment are improperly sized when a grouping contains a font size change and a table / tabular environment.

math symbols in the math environment are properly sized.

The version information is LuaTex 1.10.0, but that choice was not available in the product version drop-down
Steps To Reproducewith TexWorks install on windows 10 computer, run

latexmk -lualatex test_elz_heb.tex

A big thank-you to the creator of the elzcards style for creating most of the test file.
Additional InformationI used LuaLaTex because xelatex reported an error (using \bigcirc outside a math environment) that I didn't understand, so I tried one of the other choices. I am a LaTeX newbie. Perhaps the correct fix is to require math symbols be used inside a math environment. But I think this test file shows clearly that something in the tabular environment is leaking out of the LaTeX grouping surrounding the table definition.
TagsNo tags attached.

Activities

at7howard

2019-06-12 12:22

reporter  

test_elz_heb.tex (1,378 bytes)

at7howard

2019-06-12 12:44

reporter   ~0001705

Here is the output. If anyone would like to see any of the other files created during typesetting, let me know and I'll upload them too.

test_elz_heb.pdf (20,470 bytes)

Hans Hagen

2019-06-12 17:21

manager   ~0001706

from your description it looks like a latex issue so best report it on a relevant list (this tracker is only for luatex-the-program)

at7howard

2019-06-14 09:36

reporter   ~0001708

After reading a bit more about LuaLaTex I think I understand better. This tracker is for the implementation of the Lua programming language, while the bug I'm reporting is all from LaTeX-only code.

If that is correct, please:
1. give me hints about the relevant list to report this (I'm a newbie and I really don't know)
2. close this issue

Hans Hagen

2019-06-14 12:45

manager   ~0001709

there is a luatex mailing list at tug.org with mostly latex related traffic and there is stack exchange

Issue History

Date Modified Username Field Change
2019-06-12 12:22 at7howard New Issue
2019-06-12 12:22 at7howard File Added: test_elz_heb.tex
2019-06-12 12:44 at7howard File Added: test_elz_heb.pdf
2019-06-12 12:44 at7howard Note Added: 0001705
2019-06-12 17:21 Hans Hagen Note Added: 0001706
2019-06-14 09:36 at7howard Note Added: 0001708
2019-06-14 12:45 Hans Hagen Note Added: 0001709
2019-06-14 12:45 Hans Hagen Assigned To => Hans Hagen
2019-06-14 12:45 Hans Hagen Status new => closed
2019-06-14 12:45 Hans Hagen Resolution open => no change required