View Issue Details

IDProjectCategoryView StatusLast Update
0000763MetaPostbugpublic2012-12-10 12:13
ReporterTacoAssigned ToTaco 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version1.211 
Target VersionFixed in Version 
Summary0000763: Pen angles in SVG output
DescriptionFrom Shriramana Sharma:

I drew a simple triangle using an elliptical pen rotated by 60
degrees. The PS output is fine, but the SVG output apparently rotates
the pen *clockwise* by 60 degrees because the top-right side of the
triangle is the thinner stroke instead of the top left.

I think it has something to do with applying transformation to the
coordinate system instead of the object. I do not know SVG enough to
know whether it is possible to assign per object transformations, or
whether all per-object transformations are to be achieved by sort of
pushing the current coordinate system transform state onto a stack,
altering it as per requirements temporarily (with intended object
rotations to be applied in reverse), drawing and then popping back the
previous state from the stack. (Qt does all per-object transforms this
way.) In this case, the SVG output system of MPost/MPLib should take
care to reverse the sign of all angles before outputting. Perhaps
since MPost was designed initially for PostScript, it follows the PS
model of applying per-object transforms, but apparently the case with
SVG is different and should be fixed.
TagsNo tags attached.

Activities

Taco

2012-08-06 09:21

administrator  

mp-svgout-problem.zip (6,822 bytes)

Issue History

Date Modified Username Field Change
2012-08-06 09:21 Taco New Issue
2012-08-06 09:21 Taco File Added: mp-svgout-problem.zip
2012-09-28 15:32 Taco Status new => assigned
2012-09-28 15:32 Taco Assigned To => Taco
2012-11-12 14:20 Taco Status assigned => resolved
2012-11-12 14:20 Taco Resolution open => fixed
2012-12-10 12:13 Taco Status resolved => closed