View Issue Details

IDProjectCategoryView StatusLast Update
0001008contextbug reportpublic2019-07-07 18:31
ReportertheismAssigned To 
PrioritynormalSeverityblockReproducibilityalways
Status newResolutionopen 
PlatformOSGentoo LinuxOS Version
Product Version 
Target VersionFixed in Version 
Summary0001008: contextjit PANIC: unprotected error in call to Lua API (CPU with SSE2 required)
Descriptionin dev-texlive/texlive-context-2019
when I compile tex file:
contextjit file.tex

I get:
PANIC: unprotected error in call to Lua API (CPU with SSE2 required)

How to fix this error for PC without SSE2?
TagsNo tags attached.

Activities

Hans Hagen

2019-07-04 22:27

manager   ~0001710

Are there processors without sse2? which cpu do you have? Luajit uses machine-code level optimzations so it has some demands. Does regular luatex work ok?

theism

2019-07-04 22:38

reporter   ~0001711

I have cpu with MMX.
Yes, luatex work fine.

theism

2019-07-06 13:16

reporter   ~0001712

Is there a solution?

Hans Hagen

2019-07-07 18:31

manager   ~0001713

no, because wer'e not going to patch the luajit core machinery for an old cpu

Issue History

Date Modified Username Field Change
2019-07-04 16:54 theism New Issue
2019-07-04 22:27 Hans Hagen Note Added: 0001710
2019-07-04 22:38 theism Note Added: 0001711
2019-07-06 13:16 theism Note Added: 0001712
2019-07-07 18:31 Hans Hagen Note Added: 0001713