View Issue Details

IDProjectCategoryView StatusLast Update
0000621luatexto be consideredpublic2016-09-16 11:03
ReporterphiAssigned ToHans Hagen 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionno change required 
PlatformCore 2 DuoOSMac OS XOS Version10.6.7
Product Version0.66.0 
Target Versionmaybe never (> v 1)Fixed in Version 
Summary0000621: Actual mathstyle differs from \mathstyle after \mathchoice
DescriptionIf the mathstyle is altered directly inside a \mathchoice, the new style is still active after the mathchoice. However, the \mathstyle command expands to the style that was active before the mathchoice.
Steps To ReproducePlain example:

\def\1{\;a^a\mathstyle\;}
$$
\1
\mathchoice{\scriptstyle\1}{}{}{}
\1
$$
\bye

The third part is typeset in scriptstyle, but reads a^a0.
Additional InformationBTW, is there a reason why \mathchoice is not an integer parameter?
Tagsmath

Activities

phi

2011-05-05 00:59

reporter   ~0000832

the last question should read: BTW, is there a reason why *\mathstyle* is not an integer parameter?

Taco

2011-05-05 07:46

administrator   ~0000833

To answer the last question: because it is read-only.

phi

2011-07-14 12:18

reporter   ~0000904

I think it would be more consistent to turn \mathstyle into a read-only integer parameter like \lastpenalty or \inputlineno.

Hans Hagen

2015-10-25 11:28

manager   ~0001483

one can use grouping ... it's mostly a scanner issue as the choice scanner doesn't restore the math style as seen during scanning .. changing that now is asking for compatibility problems

\def\1{a^a[\mathstyle]}
$$
\1
{\mathchoice{\scriptstyle(\1)}{}{}{}}
\1
\mathchoice{\scriptstyle<\1>}{}{}{}
\1
$$

we can decide to add an option to restore the style after scanning choinces by default

Hans Hagen

2016-09-16 11:03

manager   ~0001644

will be explained in manual ... behaviour is as expected

Issue History

Date Modified Username Field Change
2011-05-05 00:58 phi New Issue
2011-05-05 00:59 phi Note Added: 0000832
2011-05-05 07:46 Taco Status new => assigned
2011-05-05 07:46 Taco Assigned To => Taco
2011-05-05 07:46 Taco Note Added: 0000833
2011-05-05 13:49 Taco Target Version => 0.80.0
2011-07-14 12:18 phi Note Added: 0000904
2012-04-09 04:53 Khaled Hosny Tag Attached: math
2015-10-25 10:04 Hans Hagen Target Version 0.80.0 => 0.85.0
2015-10-25 11:28 Hans Hagen Note Added: 0001483
2015-11-03 23:14 Hans Hagen Category luatex bug => to be considered
2015-11-05 11:08 Hans Hagen Target Version 0.85.0 => 0.90.0
2015-11-11 22:56 Hans Hagen Assigned To Taco => Hans Hagen
2015-11-12 15:38 Hans Hagen Target Version 0.90.0 => maybe never (> v 1)
2016-09-16 11:03 Hans Hagen Note Added: 0001644
2016-09-16 11:03 Hans Hagen Status assigned => closed
2016-09-16 11:03 Hans Hagen Resolution open => no change required