View Issue Details

IDProjectCategoryView StatusLast Update
0000267luatexfeature requestpublic2009-11-18 16:55
ReporterHans HagenAssigned ToTaco 
PrioritynormalSeverityminorReproducibilityN/A
Status closedResolutionsuspended 
Product Version 
Target Versionsubproject (> v 1)Fixed in Version0.45.0 
Summary0000267: reminder: explore impact of main loop in coroutine
Descriptionnow that we have the code in c we can look into the possibility to use coroutines to switch between lua and tex

there are several possible solutions for this:

- turn main loop into a callback which gives a lot of freedom but also moves fetching tokens etc to the lua end (can be slow)

- use a predefined main coroutine where the fetch (unless overloaded) is handled at the tex end

this need some thinking and testing esp since we don't want to slow down luatex as result of using a few coroutine switches (as most can be done without anyway)

TagsNo tags attached.

Activities

Taco

2009-11-04 17:29

administrator   ~0000322

First, I want to rewrite main_control so that it becomes a function dispatcher instead of a large case statement.

That is a lot of work, but it would make writing new primitives much easier as well as improve the readability of the code a lot, because it allows registering the handler functions via de internal primitive() function.

Taco

2009-11-09 15:02

administrator   ~0000329

The reorganization of main_control() should be done first, otherwise we run the risk of having to throw away lots of code when we finally do get around to cleaning up main_control.

Issue History

Date Modified Username Field Change
2009-09-12 13:56 Hans Hagen New Issue
2009-09-12 13:59 Hans Hagen Summary explore impact of main loop in coroutine => reminder: explore impact of main loop in coroutine
2009-11-04 17:29 Taco Note Added: 0000322
2009-11-09 15:02 Taco Status new => resolved
2009-11-09 15:02 Taco Resolution open => suspended
2009-11-09 15:02 Taco Assigned To => Taco
2009-11-09 15:02 Taco Note Added: 0000329
2009-11-09 15:02 Taco Target Version => subproject (> v 1)
2009-11-18 16:54 Taco Fixed in Version => 0.45.0
2009-11-18 16:55 Taco Status resolved => closed